Critical Adobe Flash Player Vulnerability Found, Uninstalling Only Fix for Now

Adobe has confirmed a new vulnerability in its Flash Player that affects every version of the media player meant for Windows, OS X, and Linux desktop operating systems. The discovery and the acknowledgement of its existence comes just a day after Adobe released its monthly security update. The company has assured that it will release a fix for the new vulnerability next week.

The firm revealed that the Flash Player vulnerability was discovered by security firm Trend Micro earlier this week. The company said that it will roll out an out-of-cycle security update next week to patch the said vulnerability.

In an advisory, the company said, “Adobe is aware of a report that an exploit for this vulnerability is being used in limited, targeted attacks. Adobe expects to make an update available during the week of October 19.” Until that happens, the only way to keep your computer intact from the vulnerability is to uninstall Flash.

While Adobe hasn’t discussed the nature of the vulnerability yet, security researchers at Trend Micro said the flaw can allow an attacker to take over the victim’s computer. The firm further noted that the vulnerability is already being exploited in the wild by cyberspying group Pawn Storm. The group has previously attacked governments in Asia, the White House and other notable organisations and places.

Once the go-to tool for accessing media content on Web browsers, Flash Player has been criticised for its lack of security sophistication in the recent years. As Web browsers adopt different technologies – HTML5 being one – to replace Flash, the Adobe’s tool seems to be on its way to extinction.

Leave a Reply

Your email address will not be published. Required fields are marked *

*
*